$re = '/[^_]+_[^_]+_([^_]+)_([^_]+)/';
$str = 'toto_tata_titi_tutu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);