$re = '/[a-zA-Z0-9]+/m';
$str = 'his name is "Donald" and he likes burger. on December 11, he married.
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;