$re = '/(?<=^|\. )([A-Z])/m';
$str = 'His name is "Donald" and he likes burger. On December 11, he married.
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;