// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)USE\s(?P<db>\[\w+\]);?\s*
CREATE VIEW (?P<schema>\[\w+\])\.(?P<name>\[\w+\])
AS\s*
(?P<sql>.+)").unwrap();
let string = "USE [db_name];
CREATE VIEW [schema_name].[view_name]
AS
WITH cte AS (
SELECT * from A
)
select * from cte;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}