$re = '/(?<=-|x)\d+(?=x|\.)/m';
$str = '"en/text/org-affiliate-250x450.en.gif"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);