package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\[[^[\]]*\]$)|!`)
var str = `[some tex!t !]
[som!e text !
!some text !`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}