$re = '/\d+$/m';
$str = 'hello my name123israju45678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);