re = /(?=\S)[^.]*(?:\.(?!\s)[^.]*)*?\band\b[^.]*(?:\.(?!\s)[^.]*)*\.\s+And\b/m
str = 'Text and text text. Text text. And text.
Text and text text. And text.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end