const regex = /(?=\S)(?:[^.]|\.(?!\s))*?\band\b(?:[^.]|\.(?!\s))*\.\s+And\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\S)(?:[^.]|\\.(?!\\s))*?\\band\\b(?:[^.]|\\.(?!\\s))*\\.\\s+And\\b', 'gm')
const str = `Text and text text. Text text. And text.
Text and text text. And text.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}