# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"http(|s):[^\'$\s]+"
test_str = ("head: https://scooptacular.net\n"
"head: https://scooptacular.net/img/uploaded/379d05029c0d84618c70ac037a25fd88.jpg\n"
"head: https://scooptacular.net/img/uploaded/4baaa58a1a37fd3da3e4e78caf366b7f.jpg\n"
"head: https://fonts.googleapis.com/css?family=Montserrat:400,700\n"
"head: https://fonts.googleapis.com/css?family=Kaushan+Script' rel='stylesheet' type='text/css'>\n"
"head: https://fonts.googleapis.com/css?family=Droid+Serif:400,700,400italic,700italic' rel='stylesheet' type='text/css'>\n"
"head: https://fonts.googleapis.com/css?family=Roboto+Slab:400,100,300,700' rel='stylesheet' type='text/css'>\n"
"head: https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js\n"
"head: https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js\n"
"meta: https://scooptacular.net\n"
"meta: https://scooptacular.net/img/uploaded/379d05029c0d84618c70ac037a25fd88.jpg\n"
"meta: https://scooptacular.net/img/uploaded/4baaa58a1a37fd3da3e4e78caf366b7f.jpg\n"
"meta: https://fonts.googleapis.com/css?family=Montserrat:400,700\n"
"meta: https://fonts.googleapis.com/css?family=Kaushan+Script' rel='stylesheet' type='text/css'>\n"
"meta: https://fonts.googleapis.com/css?family=Droid+Serif:400,700,400italic,700italic' rel='stylesheet' type='text/css'>\n"
"meta: https://fonts.googleapis.com/css?family=Roboto+Slab:400,100,300,700' rel='stylesheet' type='text/css'>\n"
"meta: https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js\n"
"meta: https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js\n"
"meta: https://scooptacular.net\n"
"meta: https://scooptacular.net/img/uploaded/379d05029c0d84618c70\n"
"http://google.com.ar\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.