re = /(?<=~)(?=ISA\*)/
str = 'ISA*lots**of~other~data**with~~no terminating **pattern~ISA*lots**of~other~data**with~~no terminating **pattern~ISA*lots**of~other~data**with~~no terminating **pattern~ISA*lots**of~other~data**with~~no terminating **pattern~'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end