import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(1\\s?)?(\\(\\d{3}\\)|\\d{3})[\\s\\-]?\\d{3}[\\s\\-]?\\d{4}$";
final String string = "555-555-5555\n"
+ "1 555-555-5555\n"
+ "1 (555) 555-5555\n"
+ "5555555555\n"
+ "555-555-5555\n"
+ "(555)555-5555\n"
+ "1(555)555-5555\n"
+ "555-5555\n"
+ "5555555\n"
+ "1 555)555-5555\n"
+ "1 555 555 5555\n"
+ "1 456 789 4444\n"
+ "123**&!!asdf#\n"
+ "55555555\n"
+ "(6054756961)\n"
+ "2 (757) 622-7382\n"
+ "0 (757) 622-7382\n"
+ "-1 (757) 622-7382\n"
+ "2 757 622-7382\n"
+ "10 (757) 622-7382\n"
+ "27576227382\n"
+ "(275)76227382\n"
+ "2(757)6227382\n"
+ "2(757)622-7382\n"
+ "555)-555-5555\n"
+ "(555-555-5555\n"
+ "(555)5(55?)-5555";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}