re = /(.*)/m
str = 'Is there a way to do a find and replace (regex) all uppercase characters in the matching strings with lowercase ones? Preferably in VS Code or IntelliJ I already have my regex ready.'
subst = '\\L\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result