$re = '/(?<![a-zA-Z])(0)(?![a-zA-Z])/m';
$str = 'abc0abc
abc 0abc
abc0 abc
abc 0 abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);