package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d*(\.\d{0,2})?`)
var str = `1064.12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}