re = /(?<=\()(?:[^()]|\(\))+(?=\))/m
str = 'x (a) y -> a
x (a b) y -> a b
x (a b c) y -> a b c
x (a b() c) y -> a b() c
x (a() b() c) y -> a() b() c
x (a b() c()) y -> a b() c()
x (a b(a) c) y -> a
x (a (b() c)) y -> b() c
x () y -> empty
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end