# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^
(?P<local_year>\d{4})
/
(?P<local_month>[01]\d)
/
(?P<local_day>[0-3]\d)
\,\s+
(?P<local_hour>[0-2]\d)
\:
(?P<local_minute>[0-6]\d)
\:
(?P<local_second>[0-6]\d)
\s
(?P<year>\d{4})
\-
(?P<month>[01]\d)
\-
(?P<day>[0-3]\d)
\s
(?P<hour>[0-2]\d)
\:
(?P<minute>[0-6]\d)
\:
(?P<second>[0-6]\d)
\:
(?P<microsecond>\d{3})
(?=\s)
"""
test_str = ("2022/11/13, 11:53:11 2022-11-13 19:53:11:377 | Antistasi | Info | File: A3A_fnc_initServer | Server init started\n\n"
"2022/07/03, 11:16:37 2022-07-03 18:16:37:356 | Antistasi | Error | File: A3A_fnc_initVarServer | Missing classnames: [\"flag_FIA\"] | Called By: A3A_fnc_initVar\n\n"
"2022/11/13, 11:58:41 2022-11-13 19:58:41:635 | Antistasi | Info | File: A3A_fnc_initVarServer | Loading template VN_Civ for side CIV | Called By: A3A_fnc_initServer")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.