$re = '/<@([WU][^>]*)>/m';
$str = 'Hi, <@W12313>, <@U333111>!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);