package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)([0-9]{6,}) ([0-9]{10,}) ([0-9]{4,5}) (.{5,}) ([0-9]{1,}) ([0-9\.,]{4,8}) ([0-9\.,]{4,8}+)`)
var str = `6292181 5702016627428 2304 WIDGET 18 14.12 254.16 6102211 5702015357180 10696 WIDGET 16 32.34 517.44 6332205 5702016911053 10946 WIDGET 6 32.36 194.16 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}