# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<![a-zA-Z])you(?![a-zA-Z])"
test_str = "*_you_don't_* think_you_don't_* you_don't_*_* you_don't_know_your_youth"
subst = "we"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.