package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\[[^]]+]|\w+) *\. *(\[[^]]+]|\w+)`)
var str = `Schema.TableName
Schema . TableName
[Schema].[TableName]
[Schema] . [TableName]
Schema. [TableName]
[SchemaPart1.Part2.Part 3].[Table . Name]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}