package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`javascript\.[0-9]`)
var str = `javascript.1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}