$re = '/\b[а-яё]{6}\b/ui';
$str = 'привет 123 приветп привёт мекиеи привЁт';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);