import re
regex = re.compile(r"(.*)([a-z])([A-Z]).*", flags=re.DOTALL)
test_str = "Guadel LondoneLondon"
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)