re = /\/resources\/red_\K(\w)/m
str = './resources/red_B.png
./resources/red_1.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end