$re = '/^\s*[\r\n]/im';
$str = '# H1
## H2
### H3
# A First Level Header
## Second Level Header
Now is the time for all good men to come to the aid of their country. This is just a regular paragraph.
The quick brown fox jumped over the lazy dog\'s back.
*The* quick brown fox jumped over the lazy dog\'s back.
**The** quick brown fox jumped over the lazy dog\'s back.
`The` quick brown fox jumped over the lazy dog\'s back.
[The]() quick brown fox jumped over the lazy dog\'s back.
### Header 3
> This is a blockquote.
>
> This is the second paragraph in the blockquote.
>
> ## This is an H2 in a blockquote';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;