using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(\b\w+\b)(?!\W+\1\b)(?=.*\b\1\b)";
string input = @"item1 item1, test, item3 ;
item4,item5;
test , item6;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}