re = /\b(?=[^\W\d]*\d)[\d_]*[A-Z]\w*/mi
str = 'my text contains of the 33109 following values RT3123SO55 and also with certain numbers godwil_5708 and 323stwe and 8y9yc2 456453'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end