$re = '/\'((?!(?:[^\'\s]*\s[^\'\s]*){2,}\'|(?:[^\'-]*-[^\'-]*){2,}\')(?:(?:[1-9]|10)\s?-?(?:dan|kyu|дан|кью)?-?)*)\'/i';
$str = '\'4dan-7kyu\' or \'4dan - 7kyu\' or \'10kyu\' or \'10 kyu\' or \'2dan\' or \'2 dan\' or \'4-7\' or \'4 - 7\' or \'10\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);