$re = '/^(.+?)(?: \((.+)\))?$/m';
$str = 'Title (Last, First)
Title (Author)
Title';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);