import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:AA|BB)\\s{2,}(\\S.*?)\\s{2,}(\\d+(?:\\.\\d+)*(?:-\\w+)?)";
final String string = "||/ software version some_text Description\n"
+ "+++-======================================-===================================================-============-===============================================================================\n"
+ "AA SOFTWARE1 this is some text 1.1.1.1-UBUNTU GHGFHGFH Description1\n"
+ "AA SOFTWARE2 1.1.1.2-UBUNTU_HGSFHF JGJHGKGK Description2\n"
+ "BB SOFTWARE3 1.2.3.4.5 JHGJHGJG Description3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}