$re = '/(?<=Obvious directions are:[^.]*?)\w+/m';
$str = 'Obvious directions are:
west, east, southeast, south.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);