# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:y,)([0-9AZa-z|\+|\-|\*|\.|\,|\(|\)|\/]+)\))"
test_str = ("pow(y,2)\n"
"pow(y,2+2)\n"
"pow(y,2-3)\n"
"pow(y,2.2)\n"
"pow(y,(23)/(2))+23123\n"
"pow(y,pow(2,pow(2,4)))-932\n"
"pow(y,pow(2,1*pow(2,0.5)))+23\n\n"
"//Erro\n"
"pow(y,2)*pow(2,2)\n"
"pow(y,3)-pow(2,2)\n"
"pow(y,4)+pow(2,2)\n"
"pow(y,pow(2,1*pow(2,0.5)))+pow(1,1)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.