re = /".*?"(*SKIP)(*FAIL)|(\w+)/
str = 'Lorem ipsum "dolor sit amet", consectetur adipiscing elit, maecenas est felis "sit amet"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end