# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:(\d*(?:\d*(?:.?,?)*?)*?)(.?|,?)(\d*)) ?(k|m|g|c|d|p)?(mi|bbl.|cu.|doz.|fl.? ?oz|F|ft|gal|gr|in|k|lb|mph|n.m|oz|pt|qt|sq|rpm|tablespoon|teaspoon|tbsp|tsp|td|l |m|m|b|g|kl|l |C |g|m|mt|w)(?:\/?(h|s|m)?).? *?(?:\^ *?(\d+))?)(?= |\n|\r)"
test_str = (".05 ml\n"
"50 km \n"
"30 cm^23 \n"
"12 cm\n"
"12.000.000,3 ml\n"
"12,000 ml\n"
"12,000,123.3 ml\n"
"12 km/h\n"
"12,000,123,312 ML\n"
"0.5\n\n"
"// This is a comment line. It is for human use only and is ignored by the Objective-C compiler.\n\n"
"NSString *myString;\n"
"int i = 0;\n\n"
"NSString *myString = @\"This is a //valid// string\"; //... followed by a single line comment\n\n"
"#ifndef// begin definition of pi\n"
" #define SOME_CONSTANT 3.14 // pi\n"
"#endif // end definition of pi\n\n"
"NSString *my_string = @\"Line1 \\\n"
" Line2\"; // Multine string\n\n"
"NSString *g = myString; // Comment ...\n\n"
"NSString *myString = @\"dsff; //fsdf\";\n\n"
"NSString *myString = @\"dsff\\\"; //fsdf\";\n\n"
"self.viewController.title = @\"sdfsdfs\" //sdfsdfsdf \\n \"sdfsdf\";")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.