re = /NEM12([^<]*(?:<(?!\/CSVIntervalData>)[^<]*)*)<\/CSVIntervalData>/
str = '<.CSVIntervalData>100,NEM12,201807290900,WBAYM,EEQ 200,3030910307,B1E1K1Q1,03,B1,N1,91111580,kWh,30, 300,20180728,.278,.278,.278,.278,.278,.278,.278,.278,.278,.278,.278,.278,.278,.056,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,.074,.278,.278,.278,.278,.278,.278,.278,.278,.278,.278,.278,.278,.278,E75,,,20180729000320, 900 </CSVIntervalData>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end