$re = '/(\[((\/.*\/)*\w{0,3}[^\]]+|[^\]]+)\])([\n|\s]*)({{(?:[^}{]+(\/.*\/)*[^}{]+|{{(?:[^}{]+(\/.*\/)*[^}{]+|{{(?:[^}{]+(\/.*\/)*[^}{]+|{{(?:[^}{]+(\/.*\/)*[^}{]+|{{(?:[^}{]+(\/.*\/)*[^}{]+|{{(?:[^}{]+(\/.*\/)*[^}{]+|{{(?:[^}{]+(\/.*\/)*[^}{]+|{{(?:[^}{]+(\/.*\/)*[^}{]+|{{(?:[^}{]+(\/.*\/)*[^}{]+|{{(?:[^}{]+(\/.*\/)*[^}{]+|{{(?:[^}{]+(\/.*\/)*[^}{]+|{{[^}{]*(\/.*\/)*[^}{]*}})*}})*}})*}})*}})*}})*}})*}})*}})*}})*}})*}})*/';
$str = ' [dropdown]
{{
<li class="dropdown[submenu]">
<a href="#" tabindex="-1" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false"><span class="glyphicon [icone]"></span> [titulo] <span class="caret"></span></a>
<ul class="dropdown-menu" role="menu">
[tagmaster]
[item|dropdown|novatag|header|divider]
[novatag]
{{
<li><a href="#" tabindex="-1" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false"><span class="glyphicon [icone]"></span> SUPER TAG <span class="caret"></span></a></li>
}}
[header]
{{
<li class="dropdown-header"><span class="glyphicon [icone]"> </span> [titulo]</li>
}}
[divider]
{{
<li role="separator" class="divider"></li>
}}
[/\\d/gfd|gfg()]
</ul>
</li> <!-- fim dropdown -->
}}
[/tagm[a]ster/gfd|gfg()]
{{
<div>[teste]</div>
}}
[item|dropdown]
[item]
{{
<li[ativo]{{ class="active"}}>
<a href="[url]">
<span class="glyphicon [icone]"></span> [titulo]
</a>
</li> <!-- fim item -->
}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);