const regex = /\s+$/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+$', 's')
const str = `muss der String verändert werden.
Wenn gegen inputB gematched wird, ist die Regex kein Treffer, bei \$c1B kann das Backtracking also stattfinden.
Dann habe ich noch Muffis Vorschlag aufgegriffen. In den Fällen \$c2A und \$c2B wird das Backtracking durch die Look-Behind-Assertion als nker vor dem \\s+ verhindert.
Ergebnis:
lle vier Varianten brauchen auf meiner Maschine mit Perl 5.20.2 ca. 4 Sekunden. Die Unterschiede liegen jeweils innerhalb der Schwankungsbreite zwischen zwei erneuten Durchläufen.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}