using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Regex\d{1,2}";
string input = @"Regex
Regex2
Regex20
Regex201
Regex2017";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}