#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*hello).*"
Local $sString = "----hello, how are you----" & @CRLF & _
"----how are you,hello, how are you----" & @CRLF & _
"----how are you hello, how are you----" & @CRLF & _
"----hello how are you , how are you----" & @CRLF & _
"----how are you , how are you----" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")