$re = '/[^a-z0-9\s-\']/i';
$str = 'This is a sentence-that has a ---dash in \'quotes\'.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);