#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.+\d)(?=.+[a-z])(?=.+[A-Z])(?=.+[_\.@\-])[0-9a-zA-Z_\.@\-]{6,12}$"
Local $sString = "131435456" & @CRLF & _
"a1Z!54456" & @CRLF & _
"eaze1E@AWSD" & @CRLF & _
"t.stMdpé1" & @CRLF & _
"testMdp#!5-" & @CRLF & _
"test1" & @CRLF & _
"testMdpé" & @CRLF & _
"testMdp#!5" & @CRLF & _
"testMdp " & @CRLF & _
"testMdp_750" & @CRLF & _
"78562.test" & @CRLF & _
"téstMdp_750#" & @CRLF & _
"Lm1." & @CRLF & _
"testons@2A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")