$re = '/(?<![AP]M)(?<=[a-zA-Z]),/';
$str = '2D-Digital, 1:10PM, 3:10PM, RealD-3D, 5:15PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);