import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=a\\/c|acc|account|ref|reference)\\b\\D+[0-9A-Za-z\\-\\\\\\/]+";
final String string = "My acc reference is 123456\n\n"
+ "My reference number is 123-456\n\n"
+ "My a/c reference number is 123-4556A\n"
+ "A/c number is 123-3456\n\n"
+ "This is another ref. number: 123/567-2B\n\n"
+ "cat and kitten both refer to cats.\n\n"
+ "He made reference in his novel to the 1929 census.\n\n"
+ "This data uses information from the financial year 1992/93 and also makes references to 90/91 figures.\n\n"
+ "The background property refers to a hexidecimal colour, H102567.\n\n"
+ "My a/c reference number is 123/456";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}