re = /Game(\d)\:*/m
str = 'Game 1: 3 blue, 4 red; 1 red, 2 green, 6 blue; 2 green
Game 2: 1 blue, 2 green; 3 green, 4 blue, 1 red; 1 green, 1 blue'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end