$re = '/\\\\\w\d\d;\d\s(?<first>\d)(?<second>[1-9]|\s\d)/m';
$str = '// when first value is between 1-9 second value follows it without space
2019-05-02 07:26:07.283;2019-05-02 05:26:07.283;2019-05-02 07:26:07.283;LOOKINGFORACTION;TO;SOMESTRING;FROM;SOMESTRING;MSG [223];\\x00;0 22 0 0 0 0 0 8 0 0 0 0 0 0 0 2 FC 3E ;\\x00;\\x00;\\x00;0;0
// when first value=0 => second value comes after space
2019-05-02 07:26:07.283;2019-05-02 05:26:07.283;2019-05-02 07:26:07.283;LOOKINGFORACTION;TO;SOMESTRING;FROM;SOMESTRING;MSG [223];\\x00;0 0 4 0 0 0 0 0 0 8 0 0 0 0 0 0 0 2 FC 3E ;\\x00;\\x00;\\x00;0;0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);