import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+ \\((?:[1-9]|[1234][0-9])\\)(?:, (?=\\w+ \\(\\d+\\)))?";
final String string = "I can not find a working regular expression to match the strings followed by a number from 1 to 49 in braces, in a list dividing the pairs by comma:\n\n"
+ "alpha (1), beta (12), gamma (37), delta (49), epsilon (55), zeta (64)\n\n"
+ "but also in random order and amount of pairs like\n\n"
+ "zeta (64), alpha (1), gamma (37), beta (12), delta (49), epsilon (55), eta (48), theta (26)\n\n"
+ "and also random numbers like\n\n"
+ "zeta (11), gamma (71), beta (49), delta (52), epsilon (99), alpha (33)\n\n"
+ "I'm looking for an endresult showing only the pairs with a number lower as 49 like\n\n"
+ "alpha (1), beta (12), gamma (37), delta (49)\n\n"
+ "alpha (1), gamma (37), beta (12), delta (49), eta (48), theta (26)\n\n"
+ "zeta (11), beta (49), alpha (33), \n"
+ "zeta (11), beta (49), alpha (33), test (43)\n"
+ "zeta (11), beta (49), alpha (33), test\n"
+ "zeta (11), beta (49), alpha (33), test, abc, test (33), a (a)\n"
+ "test (49), \n"
+ "test(49)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}