const regex = /\s(?:from|join)\s*(\[?[\S]+)\]?(?:\s?)(?:(?:as)?\s?)(?!(join|where|from|left|right|outer|inner|on))(\w*)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(?:from|join)\\s*(\\[?[\\S]+)\\]?(?:\\s?)(?:(?:as)?\\s?)(?!(join|where|from|left|right|outer|inner|on))(\\w*)', 'ig')
const str = `
SELECT a.ACCTNO,
case [DCCDRID] when 'N/A' then 'N/A' else dbo.GETDocNames(DCCDRID) end AS [Specific Documents Needed],
a.CUSTRF,
b.[RLEXT#],
a.APPLCT,
a.SADDR1,
a.SADDR2,
a.SCITY,
a.SSTATE,
a.SZIP,
a.CFOReqstType
FROM (
SELECT a.ACCTNO,
a.CUSTRF,
a.MINNBR,
a.[GSE_NO] AS [FNMA#],
a.GSEPN AS [FNMA MBS Pool Number],
a.GSESN AS [FNMA Master Servicer Number],
a.APPLCT,
a.SADDR1,
a.SADDR2,
a.SCITY,
a.SSTATE,
a.SZIP,
a.RefreshRunDT AS [Request Date],
a.TRANDT AS [Paid Date],
a.OrgLnBal AS [Orig Loan Amt],
b.CustodianName,
a.FileDestName,
a.CSTSEQ,
a.CSTFileDest,
a.CSTRelCode,
a.CFOOrderReasonCode,
a.CFOReqstType,
a.DCCDRID
FROM [PRODLIB].[dbo].[DOCUS_SYS_REFRESH_CFO_DAILY] a
INNER JOIN tbl_DC_CLU_CUSTD b
ON a.CSTSEQ = b.CSTSEQ
WHERE a.CSTSEQ In (23,34,35,39,53,54)
) a
INNER JOIN DOCUS_PRODLIB_CLPREFAL b
ON a.ACCTNO = b.[RLNEW#]
WHERE a.CSTSEQ = 23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}