$re = '/^(?:(\w+::\w[^:]+)\|)*(?1)$/m';
$str = '1::James is a boy|2::Hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);