import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=src=\\\\\").*?(?=\\\\\")";
final String string = "{\"Items\":[{\"ItemID\":10198,\"ItemType\":null,\"Subject\":null,\"SubjectID\":14,\"Area\":null,\"AreaID\":18,\"Topic\":null,\"TopicID\":18,\"SubTopicID\":0,\"ItemBankName\":null,\"Direction\":\"\",\"ItemTitle\":\"Q.53\",\"IsApproved\":false,\"Item\":\"\\u003cp\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003eThe\\u003c/span\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003e efficiency of the screw\\u0026nbsp;\\u003c/span\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003ein %\\u0026nbsp;\\u003c/span\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003eupto\\u003c/span\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003e two decimal places is\\u0026nbsp;\\u003c/span\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003e[quizky-text]\\u003c/span\\u003e\\u003c/p\\u003e\",\"ItemPassageID\":352,\"Passage\":\"\\u003cp\\u003e\\u003cstrong\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003eStatement\\u003c/span\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003e for Linked Answer Questions 52 and 53:\\u0026nbsp;\\u003c/span\\u003e\\u003c/strong\\u003e\\u003cbr /\\u003e \\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003eA load of 30 KN is raised by means of a screw jack having square threaded screw of pitch 12 mm. The spindle diameter is 50 mm. If a force of 350 N is applied at the end of a lever to raise the load, co-efficient of friction\\u0026nbsp;\\u003c/span\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003eis\\u003c/span\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003e 0.15.\\u003c/span\\u003e\\u003c/p\\u003e\",\"PassageTitle\":null,\"IsLinkedQuestion\":false,\"Points\":0,\"Explanation\":\"\\u003cp\\u003e\\u003cspan style=\\\"font-family: Symbol;\\\"\\u003eh\\u003c/span\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003e =\\u0026nbsp;\\u003c/span\\u003e\\u003cimg style=\\\"vertical-align: bottom;\\\" src=\\\"QUIZKYIMAGEREPO/docximg_1128711867_image197.png\\\" alt=\\\"\\\" width=\\\"54\\\" height=\\\"32\\\" data-docx-image=\\\"image197.emf\\\" /\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003e =\\u0026nbsp;\\u003c/span\\u003e\\u003cimg style=\\\"vertical-align: bottom;\\\" src=\\\"QUIZKYIMAGEREPO/docximg_1128711867_image198.png\\\" alt=\\\"\\\" width=\\\"40\\\" height=\\\"31\\\" data-docx-image=\\\"image198.emf\\\" /\\u003e\\u003cspan style=\\\"font-size: 14.7px;\\\"\\u003e = 33%\\u003c/span\\u003e\\u003c/p\\u003e\",\"ItemBankID\":0,\"LOD\":null,\"LODID\":2,\"ItemBank\":0,\"QuestionPaper\":0,\"IsProofRead\":false,\"CorrectIndex\":0,\"QuestionPaperSectionID\":0,\"ItemOptionModel\":null}],\"ItemOptions\":[{\"ItemOptionID\":37637,\"ItemID\":0,\"Option\":\"\\u003cp\\u003e\\u003cspan style=\\\"font-family: Arial; font-size: 12px;\\\"\\u003e\\u0026nbsp;\\u003c/span\\u003e\\u003cspan style=\\\"font-family: Arial; font-size: 12px;\\\"\\u003e33.36\\u003c/span\\u003e\\u003c/p\\u003e\",\"RHSOption\":null,\"MarkedIndex\":null,\"OrderNumber\":null,\"OptionIndex\":0,\"IsCorrect\":false,\"IsHTML\":false,\"RHSIsHTML\":false,\"ColumnID\":0},{\"ItemOptionID\":37638,\"ItemID\":0,\"Option\":\"\\u003cp\\u003e\\u003cspan style=\\\"font-family: Arial; font-size: 12px;\\\"\\u003e\\u0026nbsp;\\u003c/span\\u003e\\u003cspan style=\\\"font-family: Arial; font-size: 12px;\\\"\\u003e33.36\\u003c/span\\u003e\\u003c/p\\u003e\",\"RHSOption\":null,\"MarkedIndex\":null,\"OrderNumber\":null,\"OptionIndex\":0,\"IsCorrect\":false,\"IsHTML\":false,\"RHSIsHTML\":false,\"ColumnID\":0}]}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}